Completed
The scheduled maintenance has been completed.
Posted Nov 17, 2025 - 05:00 SAST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 17, 2025 - 03:00 SAST
Scheduled
The Aggregation system will be undergoing maintenance on Monday 17th November from 3am for 2 hours.
There will be processing disruptions intermittently during the stated times.
Posted Nov 14, 2025 - 14:57 SAST
This scheduled maintenance affected: Payfast Aggregation: Instant EFT (Absa Pay, Bidvest Bank, Capitec Pay, FNB, Investec, Nedbank, Tyme Bank), Payfast Aggregation: Cards (3D Secure, Absa involved transactions, American Express involved transactions, Bidvest involved transactions, Capitec involved transactions, Discovery involved transactions, FNB involved transactions, Investec involved transactions, Multi-Currency Pricing, Nedbank involved transactions, Recurring Payments, Standard Bank involved transactions, Aggregation Card Updates), Integrations and APIs (Aggregation Button/Link payments, Aggregation Shopify, Aggregation WooCommerce, Aggregation Xero), and General (Aggregation Processing (non Payment method specific), Aggregation Callbacks/ITN, Aggregation Emails, Aggregation Immediate Payouts, Aggregation Merchant Dashboard, Aggregation Payouts, Aggregation Refunds).