Completed
The scheduled maintenance has been completed.
Posted Aug 24, 2025 - 04:00 SAST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2025 - 02:00 SAST
Scheduled
The Aggregation platform will be undergoing maintenance on Sunday morning 24th August 2025 for 2 hours from 2am.
There will be intermittent disruption to processing during this time-frame.
Posted Aug 21, 2025 - 14:35 SAST
This scheduled maintenance affected: Payfast Aggregation: Instant EFT (Absa Pay, Bidvest Bank, Capitec Pay, FNB, Investec, Nedbank, Standard Bank, Tyme Bank), Payfast Aggregation: Alternative Payment Methods (Apple Pay, Mobicred, MoreTyme, Original Debit card payment method, Mukuru Cash, Samsung Pay, Scan to Pay, SCode, SnapScan, Store Cards (RCS), Zapper), Payfast Aggregation: Point of Sale (In-store payments), Payfast Aggregation: Cards (3D Secure, Absa involved transactions, American Express involved transactions, Bidvest involved transactions, Capitec involved transactions, Discovery involved transactions, FNB involved transactions, Investec involved transactions, Multi-Currency Pricing, Nedbank involved transactions, Recurring Payments, Standard Bank involved transactions), and General (Aggregation Merchant Dashboard, Aggregation Refunds, Aggregation Sandbox (test platform)).