FnB Payments

Incident Report for Payfast

Resolved

This problem has been resolved for FnB payments.
Posted Nov 28, 2025 - 15:13 SAST

Monitoring

We have noted a recovery for FNB card payments.
Posted Nov 28, 2025 - 14:53 SAST

Identified

We are seeing intermittent issues with FnB processing across both Aggregation and Gateway Platforms currently.
We are in contact with External Partners on the matter.
Posted Nov 28, 2025 - 14:37 SAST
This incident affected: Payfast Aggregation: Instant EFT (FNB), Payfast Gateway: Cards (FNB involved transactions), Payfast Gateway: SiD (FNB), and Payfast Aggregation: Cards (FNB involved transactions).