NPO donation page under maintenance

Incident Report for Payfast

Resolved

The NPO donation page is operational again.
Posted Apr 16, 2025 - 12:46 SAST

Monitoring

The charity donation page has been temporarily disabled for maintenance. Donations to NPO's are still available via the relevant merchant integrations.
Posted Apr 10, 2025 - 15:30 SAST
This incident affected: General (Aggregation Donation Page for NPO's).