FNB on EFT
Incident Report for Payfast
Resolved
This problem has resolved.
Posted Aug 23, 2024 - 11:33 SAST
Identified
A problem with FNB Payments on both Aggregation Instant EFT and Gateway SiD has been identified.
Posted Aug 23, 2024 - 10:36 SAST
This incident affected: Payfast Aggregation: Instant EFT (FNB) and Payfast Gateway: SiD (FNB).