3d Secure verification issues
Incident Report for Payfast
Resolved
This incident has been resolved
Posted Dec 12, 2023 - 02:15 SAST
Update
We are continuing to work on a fix for this issue.
Posted Dec 12, 2023 - 01:57 SAST
Identified
The issue has been isolated to a problem with international links involving Visa and Mastercard.
We will update if/when more information becomes available or when the situation resolves.
Posted Dec 12, 2023 - 00:36 SAST
Investigating
A problem with 3d Secure has been identified and escalated with external partners.
Posted Dec 11, 2023 - 22:30 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).