Visa card transactions and 3D Secure

Incident Report for Payfast

Resolved

This problem has resolved for Visa card holders.
Posted Nov 03, 2025 - 12:40 SAST

Update

We are enaging with externals to resovle this problem
Posted Nov 03, 2025 - 12:28 SAST

Identified

A problem with card processing for Visa card holders (affecting multiple banks) has been identified during the 3D Secure leg of transactions on both Aggregation and Gateway.

We are in contact with External Partners on the issue.
Posted Nov 03, 2025 - 12:20 SAST
This incident affected: Payfast Gateway: Cards (3D Secure) and Payfast Aggregation: Cards (3D Secure).