Standard acquiring on gateway

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 03:03 SAST

Update

We are continuing to investigate this issue.
Posted Jul 17, 2025 - 02:04 SAST

Investigating

Dear valued merchant,

Please be advised that SBSA acquiring seems to be down. We are working with them to try and resolve the issue.

We will update you as soon as we have more information.
Posted Jul 17, 2025 - 02:04 SAST
This incident affected: Payfast Gateway: Cards (Standard Bank involved transactions).