Investec and Tyme on SiD
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 06:42 SAST
Identified
Please note that Investec and Tyme Payments via SiD on Gateway are currently experiencing a processing problem.
Kindly opt to pay using an alternative payment method where available for the moment.
Posted Oct 04, 2024 - 10:18 SAST
This incident affected: Payfast Gateway: SiD (Investec Bank, Tyme Bank).