Aggregation payments

Incident Report for Payfast

Resolved

Issue has been resolved and services restored.
Posted Feb 10, 2026 - 22:15 SAST

Investigating

We are currenctly experiencing technical issues with upstream service providers. Issue is urgently being investigated
Posted Feb 10, 2026 - 21:57 SAST
This incident affected: Payfast Aggregation: Cards (3D Secure).