Seacom troubles
Incident Report for Payfast
Resolved
The general internet problem across the country seems to be resolving. We continue to monitor for any system change.
Posted Mar 14, 2024 - 16:07 SAST
Identified
Please note that Visa Issued cards and some external providers are encountering problems due to Seacom cable issues.
Posted Mar 14, 2024 - 13:33 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments, Recurring payments).