Completed
The scheduled maintenance has been completed.
Posted Feb 15, 2025 - 22:00 SAST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 15, 2025 - 20:00 SAST
Scheduled
The Gateway system will be undergoing maintenance on Saturday 15th February 2025 from 8pm for 2 hours.
Processing via Gateway will be impacted during this time.
Posted Feb 07, 2025 - 13:21 SAST
This scheduled maintenance affected: Payfast Gateway: SiD (Absa, African Bank, Bidvest Bank, Capitec Pay, Discovery Bank, FNB, Investec Bank, Nedbank, Standard Bank, Tyme Bank), Payfast Gateway: Alternative Payment Methods (Apple Pay, Mobicred, Momopay, PayPal, Samsung Pay, Scan to Pay, Store Cards (RCS), Visa Checkout, Zapper), and Payfast Gateway: Cards (3D Secure, Absa involved transactions, Bidvest involved transactions, Capitec involved transactions, Discovery involved transactions, FNB involved transactions, Investec involved transactions, Nedbank involved transactions, Standard Bank involved transactions, American Express involved transactions).