Standard Bank EFT payments

Incident Report for Payfast

Monitoring

A fix has been implemented which have resolved the issue on SiD, and we are monitoring the result.

Teams are actively working on implementing a fix for InstantEFT.
Posted Oct 23, 2025 - 13:00 SAST

Identified

A problem with EFT payments for Standard Bank affecting both Aggregation Instant EFT and Gateway SiD has been identified.
For the moment, please use an alternative payment method such as Credit Card or QR Codes where possible.
Posted Oct 17, 2025 - 09:42 SAST
This incident affects: Payfast Aggregation: Instant EFT (Standard Bank) and Payfast Gateway: SiD (Standard Bank).