Capitec Payment problems
Incident Report for Payfast
Resolved
This problem has resolved.
Posted Jul 08, 2024 - 11:30 SAST
Identified
Capitec Issuing on 3d Secure is currently down affecting card issuers.
Capitec Pay for Instant EFT is also affected.
Posted Jul 08, 2024 - 09:30 SAST
This incident affected: InstantEFT (Capitec) and Credit & Cheque cards (Capitec involved transactions).