FNB EFT payments

Incident Report for Payfast

Resolved

This problem has been resolved for FnB EFT payments.
Posted Sep 19, 2025 - 15:10 SAST

Identified

An issue with FNB EFT payments has been identified.

Buyers need to log into their FnB profiles and remove a pop-up that is occurring for FnB accounts.
Once the pop-up with Terms and Conditions is removed, the transaction will process.
Posted Sep 15, 2025 - 12:37 SAST
This incident affected: Payfast Aggregation: Instant EFT (FNB) and Payfast Gateway: SiD (FNB).