MCP payments

Incident Report for Payfast

Resolved

This problem has been resolved for MCP payments.
Posted May 13, 2025 - 13:22 SAST

Identified

A problem with Multi-Currency Pricing payments has been identified and is being looked into currently. This will affect non-South African Rand payments.
Posted May 13, 2025 - 12:19 SAST
This incident affected: Payfast Aggregation: Cards (Multi-Currency Pricing).