Multi-Currency Pricing

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Jul 26, 2025 - 07:43 SAST

Update

We are continuing to work on a fix for this issue.
Posted Jul 25, 2025 - 16:25 SAST

Identified

We have identified a problem with MCP payments. Teams are attending to this matter at hand to resolve this issue.
Posted Jul 25, 2025 - 16:24 SAST
This incident affected: Payfast Aggregation: Cards (Multi-Currency Pricing).