3D Secure degradation

Incident Report for Payfast

Resolved

This problem affecting the 3D Secure leg of card transactions has been resolved.
Posted Apr 11, 2025 - 18:55 SAST

Identified

A problem for Absa card-holders completing the 3D Secure leg of card transactions has been identified.
We are in contact with External Partners on the matter.
Posted Apr 11, 2025 - 18:29 SAST
This incident affected: Payfast Gateway: Cards (3D Secure, Absa involved transactions) and Payfast Aggregation: Cards (3D Secure, Absa involved transactions).