Capitec degraded
Incident Report for Payfast
Resolved
Capitec Pay has recovered as well on Instant EFT.
Posted Jul 19, 2024 - 09:54 SAST
Update
Capitec Issuing on 3d Secure has recovered. Capitec Pay is still degraded on Instant EFT
Posted Jul 19, 2024 - 09:37 SAST
Identified
Please note that Capitec Pay as well as Capitec Issuing in 3d Secure are encountering problems at the moment.
Posted Jul 19, 2024 - 07:30 SAST
This incident affected: Payfast Aggregation: Instant EFT (Capitec Pay).