FNB EFT problems

Incident Report for Payfast

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 12:56 SAST

Investigating

A problem with FnB Payments on both Gateway SiD and Aggregation Instant EFT has been identified. We are in contact with External Partners on the problem
Posted Sep 02, 2026 - 09:48 SAST
This incident affected: Payfast Aggregation: Instant EFT (FNB) and Payfast Gateway: SiD (FNB).