Degraded 3d Success rate
Incident Report for Payfast
Resolved
This problem has been resolved with our Upstream Partners
Posted Dec 30, 2023 - 14:55 SAST
Update
We are continuing to work on a fix for this issue.
Posted Dec 30, 2023 - 14:51 SAST
Update
We are continuing to work on a fix for this issue.
Posted Dec 30, 2023 - 14:51 SAST
Identified
A problem with Mastercard issuers has been identified, affecting Capitec, Nedbank, and Standard Bank cards.
This has been escalated with relevant partners.
Posted Dec 30, 2023 - 13:30 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).