Standard Bank Auths

Incident Report for Payfast

Resolved

This problem affecting Standard Bank card-holders has been resolved.
Posted May 14, 2025 - 19:15 SAST

Identified

A problem affecting Standard Bank card-holders has been identified. This is impacting credit card payments on both Aggregation and Gateway currently.
We are in contact with External Partners on the matter.
Posted May 14, 2025 - 16:47 SAST
This incident affected: Payfast Gateway: Cards (Standard Bank involved transactions) and Payfast Aggregation: Cards (Standard Bank involved transactions).