Completed
The scheduled maintenance has been completed.
Posted Feb 16, 2025 - 00:00 SAST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 15, 2025 - 22:01 SAST
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 11, 2025 - 12:54 SAST
Scheduled
The Aggregation system will be undergoing maintenance on Saturday 15th February 2025 from 10pm for 2 hours.
Processing via Aggregation will be impacted during this time.
Posted Feb 07, 2025 - 13:18 SAST
This scheduled maintenance affected: Payfast Aggregation: Instant EFT (Absa, African Bank, Bidvest Bank, Capitec Pay, FNB, Investec, Nedbank, Standard Bank, Tyme Bank), Payfast Aggregation: Alternative Payment Methods (Apple Pay, Mobicred, MoreTyme, Original Debit card payment method, Mukuru Cash, Samsung Pay, Scan to Pay, SCode, SnapScan, Store Cards (RCS), Zapper), Payfast Aggregation: Point of Sale (In-store payments), and Payfast Aggregation: Cards (3D Secure, Absa involved transactions, Bidvest involved transactions, Capitec involved transactions, Discovery involved transactions, FNB involved transactions, Investec involved transactions, Nedbank involved transactions, Standard Bank involved transactions, Recurring Payments, American Express involved transactions).